BGP Dual-Stack կամ քայլ IPv4-ից IPv6

| Հոկտեմբեր 1, 2012 | Մեկնաբանված չէ |

BGP Dual-Stack (ipv4 համատեղ ipv6)
խնդիրը` peerեր ունենալ և IPv4-ով և IPv6-ով
քայլ առ քայլ.
նախ և առաջ, ինտերֆեյսի վրա ավելացնում ենք IPv6-ը
(ենթադրվում ա, որ v4 հասցեն արդեն կա)

ipv6_test#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ipv6_test(config)#interface FastEthernet0
ipv6_test(config-if)# ipv6 address 2001:AF1::2009/112
ipv6_test(config-if)#

հետո “միացնում” ենք IPv6-ը (ipv6 unicast-routing)

ipv6_test#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ipv6_test(config)#ipv6 unicast-routing
ipv6_test(config)#ipv6 cef

անցնում ենք BGP-ի կոնֆին`

ipv6_test#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ipv6_test(config)#router bgp 35
ipv6_test(config-router)# no bgp default ipv4-unicast
ipv6_test(config-router)# bgp log-neighbor-changes
ipv6_test(config-router)# neighbor 2001:AF1::2008 remote-as 34
ipv6_test(config-router)# neighbor 10.10.20.1 remote-as 29

հիմա ունենք 2 peer
1. 2001:AF1::2008 IPv6-ով
2. 10.10.20.1 IPv4-ով
բայց պետք ա ըստ տարբերակի իրենց address-family-ի մեջ ներառել ու “ակտիվացնել”

ipv6_test#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ipv6_test(config)#router bgp 35
ipv6_test(config-router)# address-family ipv4
ipv6_test(config-router-af)# neighbor 10.10.20.2 activate
ipv6_test(config-router-af)#exit
ipv6_test(config-router)# address-family ipv6
ipv6_test(config-router-af)# neighbor 2001:AF1::2008 activate
ipv6_test(config-router-af)#^Z
ipv6_test#
*Mar 25 13:20:21.918: %SYS-5-CONFIG_I: Configured from console by console
ipv6_test#

էս պահին ունենք 2 ակտիվ peer-եր, որոնց հետ կարելի established BGP connection ունենալ. մեկը 10.10.20.1 մյուսն էլ 2001:AF1::2008:

ընդանուր BGP-ի տեսքը`

router bgp 35
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.10.20.1 remote-as 29
neighbor 2001:AF1::2008 remote-as 34
!
address-family ipv4
neighbor 10.10.20.1 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor 2001:AF1::2008 activate
exit-address-family

սա մինիմալ կարգավորումնա ա կապ հաստատելու համար:

ՍկզբնԱղբյուր

Նշագրեր: , , ,

Բաժին: Ցանցի կառավարում (Network Administration)

Կիսվել , տարածել , պահպանել

VN:F [1.9.20_1166]
Rating: 0.0/10 (0 votes cast)

Մեկնաբանեք

Կհաստատվեն միայն մեսրոպատառ հայերենով գրած մեկնաբանությունները

204